X52 lights don't light up

Ask Questions & Get Help.
User avatar
Jsick7x
Captain
Captain
Posts: 31
Joined: 03 May 2016, 18:16
Location: USA
United States of America

X52 lights don't light up

#1

Post by Jsick7x » 27 Feb 2017, 16:10

I bought an X52 Pro six months ago and the lights on the throttle piece wont light up. What's weird is that if I plug the USB in my PC half way, it lights up and it also lights up when using Windows 10. Any ideas?
Image

User avatar
JINX
Major
Major
Posts: 210
Joined: 13 Oct 2015, 20:41
Location: Maryland, USA
United States of America

Re: X52 lights don't light up

#2

Post by JINX » 27 Feb 2017, 16:23

Greetings fellow x-52'er. Go into the Control Panel> r-click on the X-52 to properties > select the tab that says LEDs. Then you can assign them whatever color you want (i think red, green, yellow...and blue - not sure on blue though).

Here's also a link to the online manual.

http://www.saitek.com/manuals/x52_manual.pdf

Another problem I've experienced often...once I plug the USP of the HOTAS into the computer it sometimes doesn't have a true 'zero' on some of the Axis for some reason or other. So for example my pitch will constantly be trying to pull the plane into the ground, or up into the heavens...or a constant roll. I think maybe the stick is moved out of center when the USB is connected to the program sets that as default. To fix the issue I unplug the connection cable into the flight stick, re-insert (giggity) and it magically fixes it.
Image

User avatar
Jsick7x
Captain
Captain
Posts: 31
Joined: 03 May 2016, 18:16
Location: USA
United States of America

Re: X52 lights don't light up

#3

Post by Jsick7x » 27 Feb 2017, 17:15

So, I download the MadCatz software, and while starting that up it says, "No controllers found".
Image

User avatar
JINX
Major
Major
Posts: 210
Joined: 13 Oct 2015, 20:41
Location: Maryland, USA
United States of America

Re: X52 lights don't light up

#4

Post by JINX » 27 Feb 2017, 17:25

Not sure about the Madkatz stuff....but you can install the needed drivers from Saitek here (sounds like that is what is missing...controller no found)

http://www.saitek.com/uk/down/drivers.php

Select "pro flight range" > X52 pro > indicate your OS > DL the software & drivers
Image

User avatar
Jsick7x
Captain
Captain
Posts: 31
Joined: 03 May 2016, 18:16
Location: USA
United States of America

Re: X52 lights don't light up

#5

Post by Jsick7x » 27 Feb 2017, 17:55

So I download the X52 Pro drivers and software. The software is different than what the manual shows.

The manual shows:
http://prntscr.com/ee2r4h

What I downloaded off of Saitek :
http://prntscr.com/ee2rx0
Image

User avatar
Jsick7x
Captain
Captain
Posts: 31
Joined: 03 May 2016, 18:16
Location: USA
United States of America

Re: X52 lights don't light up

#6

Post by Jsick7x » 27 Feb 2017, 17:59

Okay I found the right menu in my control panel. So however everything is on for my LEDs.

http://prntscr.com/ee2u16
Image

User avatar
JINX
Major
Major
Posts: 210
Joined: 13 Oct 2015, 20:41
Location: Maryland, USA
United States of America

Re: X52 lights don't light up

#7

Post by JINX » 27 Feb 2017, 18:14

Some other trouble shooting then (sorry if this is redundant but sometimes the PC just is not plugged into the wall)..

After the DLs did you try a system restart? Also I've read that ensuring the connecting PS2 cable is seated correctly, and lastly try an other USB port.
Image

User avatar
runny
Lieutenant Colonel
Lieutenant Colonel
Posts: 717
Joined: 21 Jun 2015, 01:40
Location: Alberta
Canada

Re: X52 lights don't light up

#8

Post by runny » 27 Feb 2017, 23:13

I believe USB 3.0 and USB 2.0 make a difference.
Image

User avatar
Jsick7x
Captain
Captain
Posts: 31
Joined: 03 May 2016, 18:16
Location: USA
United States of America

Re: X52 lights don't light up

#9

Post by Jsick7x » 28 Feb 2017, 22:35

Alrighty boys, so I have tried 3.0s and 2.0 slots. Ive restarted, plugged it into every port I can think of and the lights still wont light up. But in the end it is not a big deal I suppose!
Image

User avatar
Weaz3L
Major
Major
Posts: 39
Joined: 29 Feb 2016, 09:03
Location: Colorado
United States of America

Re: X52 lights don't light up

#10

Post by Weaz3L » 07 Mar 2017, 05:42

Jsick7x wrote:
27 Feb 2017, 17:59
Okay I found the right menu in my control panel. So however everything is on for my LEDs.

http://prntscr.com/ee2u16
Did you try clicking on the setting again? On mine you just tap the slider and they should pop on.
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests