X55 Ghosting issue

Ask Questions & Get Help.
Post Reply
User avatar
Narokuu
Captain
Captain
Posts: 214
Joined: 08 Aug 2015, 01:03
Location: USA
United States of America

X55 Ghosting issue

#1

Post by Narokuu » 22 Apr 2017, 03:00

As the title says, i am unable to play due to my HOTAS, randomly ghosting keys. have gone through every possible situation. Cannot figure out why.

Bought a brand new powered USB hub, it only seems to happen on the Throttle, the stick never does it. have contacted logitech/Saitek and they have given me the typical crap. drivers software blah blah. if i had the money i would just get a new one. Sadly its not an option. So im Sol until otherwise noted.

If anyone has any miracle cures or advice, i am all ears.
Image

User avatar
Brady
1st Lieutenant
1st Lieutenant
Posts: 38
Joined: 02 Dec 2016, 23:21
Location: Montana
United States of America

Re: X55 Ghosting issue

#2

Post by Brady » 22 Apr 2017, 22:32

All I've ever really heard as far as ghosting with the X55 is that it's due to lack of power to the USB's. I would try plugging both usb's into the MOBO and see if that solves it. I have an X55 as well, but have never had any problems with ghosting. Hope you find a solution!

User avatar
LokiV7
Captain
Captain
Posts: 70
Joined: 25 Jul 2016, 09:35
Location: Illinois
United States of America

Re: X55 Ghosting issue

#3

Post by LokiV7 » 22 Apr 2017, 23:09

VoiceAttack all the buttons .. !

User avatar
Alphaskoom
Major
Major
Posts: 202
Joined: 21 Jun 2015, 07:56
Location: Texas
United States of America

Re: X55 Ghosting issue

#4

Post by Alphaskoom » 23 Apr 2017, 00:29

how long have you had the X55, i had issues with mine shortly before one of the hat switches quit, its most likely wore out and cables are fraying, look up any X55 in depth review (where they take it apart) and saitek decided not to loom the massive amount of wires that are inside the throttle. i went through 2 of them before the third one they sent me was acceptable, of course this was after they had a mistake and sent me an X56 as a were sorry it took so long thing... realistically i feel as though it was a mistake on their part cause the X55 came with the replacement date for the original warranty claim.. anywho its probly a mechanical issue, wires related... if i was in the market for a hotas right now, it would definitely be thrustmasters T16000M Flight control system (https://www.amazon.com/Thrustmaster-T-1 ... rustmaster) though not as many buttons, i feel this is a viable option for those who cant spend the 400+ for the Warthog Hotas... or you can contact saitek support and continuously harrass them until they allow you to ship it off to them at your cost, to recieve a refurbished one thats hopefully better than yours
Image

User avatar
pyromaniac4002
Colonel
Colonel
Posts: 1478
Joined: 21 Jun 2015, 02:45
Location: Orange County, California
United States of America

Re: X55 Ghosting issue

#5

Post by pyromaniac4002 » 23 Apr 2017, 04:23

I heard from Naro that he has since fixed the issue (at least until we jinx it by talking about it and it comes back up). He turned off the LEDs and it decreased the power draw to a level where the ghosting stops. Apparently it doesn't matter if it's on a powered USB hub or what, Saitek just wants to punish you for your fascination with bright lights.
Image

User avatar
Brady
1st Lieutenant
1st Lieutenant
Posts: 38
Joined: 02 Dec 2016, 23:21
Location: Montana
United States of America

Re: X55 Ghosting issue

#6

Post by Brady » 23 Apr 2017, 07:32

Ah ha, I never have the lights on. I'll recommend that next time around.

User avatar
Narokuu
Captain
Captain
Posts: 214
Joined: 08 Aug 2015, 01:03
Location: USA
United States of America

Re: X55 Ghosting issue

#7

Post by Narokuu » 23 Apr 2017, 14:35

Thanks everyone for all of the help, pyro is correct its always the LED's that ruin peoples fun. But this does to seem to fix it. ill be going through each air frame that i fly today on 1.5 and 2.0 to confirm but i was able to fly multiple A10c flights without my engines being cut off, So for me that is a victory, also when i tab to teamspeak or other window, its not SPAMMING a command into said window. That was the most frustrating part of it

All in all a victory. i Like my X55, really didn't want to have to invest in another one

As for Voice attack Loki, i NEED to start using that again, i use the crap out of it in Elite dangerous as its invaluable. i just get lazy and forget about it.

Thanks to all who responded, make sure we pass on that when it comes to LED's we just say NO. :lol:
Image

Cygon_Parrot
Platinum Member
Platinum Member
Posts: 826
Joined: 01 Jul 2015, 03:30
Ecuador

Re: X55 Ghosting issue

#8

Post by Cygon_Parrot » 23 Apr 2017, 15:31

A bit off topic, but I'll report it here just the same, as the root cause of my own problem always should be considered, too.

Logitech Extreme 3D Pro. Started getting problems with full and free movement of the axes in DCS. I even dismantled the joystick to see if there was anything pinched, chafing or frayed.

Thinking about it, the problem "coincidentally" started just after a Win 10 update. I found the work around by replugging in the joystick every time after launching DCS, and everything is good again. Don't know what they do... :unsure:

User avatar
JINX
Major
Major
Posts: 216
Joined: 13 Oct 2015, 20:41
Location: Maryland, USA
United States of America

Re: X55 Ghosting issue

#9

Post by JINX » 24 Apr 2017, 11:18

pyromaniac4002 wrote:
23 Apr 2017, 04:23
jinx it
jinx it

jinx it

jinx it

jinx it

Image
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest